All Forums -> Forum: Dynamics GP Adapter for Insight -> Topic: Decimal Places passed in on Unit Pric...
Forum Topic: "Decimal Places passed in on Unit Price does not match setup "

I am getting the following error message:

Error From Dynamics GP: Decimal Places passed in on Unit Price does not match setup (4646)

Check the following fields on the SOP Transaction Line object: 'Unit Price'.

When inserting into the field “Unit Price” (UNITPRCE) of the table “SOP Transaction Line” (SOP10200).

This happen only when we used more than 2 decimal places to fill the “Unit Price” field (We are trying to use 5 decimal places).

Background:

Basically, we are trying to copy data from the two columns TotalPrice and UsersUnits from SalesForce to GP. The original order is in USD, so the originating currency is USD. The functional currency is setup in our GP to be CDN.  

We do not have Unit Prices for our products, they are a calculated value.  We take the value of the customers PO lineitem (say $2000USD) and divide by the number of users (say 3).  We MUST have the extended price equal $2000USD and the quantity must be 3 on the order.  All other values can be calculated.  Taking the ORUNTPRC at 5 decimal places reduces the rounding issues when we transfer to invoice.  The resulting invoice value MUST match the PO amount or we will not be paid.  

We first thought that we should fill the two columns oruntprc (Originating Unit Price), and oxtndprc (Originating Extended Price). When we tried this, zero values were inserted in all price fields!! So we tried instead to insert into the two column unitprce (Unit Price)  and XTNDPRCE (Extended Price). This worked, but only when we used 2 decimal places.

Data Source: Opportunity Line Item

TotalPrice (USD)

Users_Units__c

Target: Sop Transaction line (SOP10200)

quantity = Users_Units__c

unitprce (CAD) = Round ( line.TotalPrice / line.Users_Units__c , 5) (USD)

oruntprc (USD) = calculated automatically

XTNDPRCE (CAD) = TotalPrice (USD)

oxtndprc (USD) = calculated automatically

 

Posted by Haydar H on Aug 31, 2009 03:20PM Return to top
endorsed

The number of decimal places accepted by Great Plains is determined by Great Plains and/or econnect.  Please check the setup within GP for these settings. 

The errors thrown are given by the eConnect product.  Scribe will pass eConnect any number of decimal places you wish, but if eConnect or GP does like the extended number of decimal places they will throw an error.

 

Posted by Josh S Power User on Oct 30, 2009 01:21PM Return to top

Did you manage to solve this problem. i have a very similar issue. I'm trying to import non-inventory items and qty is setup for 2dp and currency for 4, but every time I use more than 2dp I get the erro about numbe rof decimal places. As far as I can tell GP is correctly configured. Is there anything to configure for econnect , and if so where do I do this

TIA

Matt

Posted by Matt G on Apr 19, 2010 10:07PM Return to top
Add Comment Back to Topics